63509

Schreib einen Text •  • Forum •  • Neue Beiträge

63509 Impulsübertragung per Funk - Harry 24. Januar 2018 22:19:30

Nach einigen Versuchen mit verschiedenen Schaltungsvarianten bin ich jetzt letztlich an der im Schaltbild angegebenen Version hängen geblieben. Ich habe diese Schaltung auf Steckboard und auf Lochraster aufgebaut und 2 Tage lang getestet. Bis jetzt ist noch kein Fehler aufgetreten.
Den Anschluss am HT12E (Transmission enable TE) konnte ich nirgendwo anders unterbringen als an Masse. Ansonsten würde die Schaltung nicht funktionieren. Aber irgend einen Sinn muss der doch haben, sonst wäre er nicht auf einen Pin gelegt.
Das Sendermodul soll angeblich nur dann senden, wenn es einen Impuls erhält und danach wieder in den Ruhezustand übergehen. Das wäre dann ok.

Für weitere Vorschläge bezüglich der Schaltung, wäre ich dankbar.

Gruß Harry

ht tps://imgur.com/8KPMHNJ


63510 Re: Impulsübertragung per Funk - el-haber 25. Januar 2018 13:32:2063509

Herzlichen Glückwunsch!

zu dem Anderen Thema mit dem Filter hab ich Dir was in die Community geschrieben.

vu
St


63511 Re: Impulsübertragung per Funk - Theodor Wadelow 25. Januar 2018 17:29:2063509

Hallo Harry,

> Nach einigen Versuchen mit verschiedenen Schaltungsvarianten bin ich jetzt letztlich an der im Schaltbild angegebenen Version hängen geblieben.
> [ ht tps://imgur.com/8KPMHNJ ]
> Ich habe diese Schaltung auf Steckboard und auf Lochraster aufgebaut und 2 Tage lang getestet. Bis jetzt ist noch kein Fehler aufgetreten.
Glückwunsch, es funktioniert!

Im aktuellen Schaltschema (ein Plan ist es offensichtlich nicht denn z.B. die Keramikkondensatoren and en IC-Versorgungen sind nicht eingezeichnet)
sehe ich wieder "315 MHz" Funkmodul. Wie kommt das? Servierst Du uns hier Schaltschemata anderer Leute oder Hast du wirklich wieder ein nicht lizenziertes 315 MHz-Modul eingebaut?

> Den Anschluss am HT12E (Transmission enable TE) konnte ich nirgendwo anders unterbringen als an Masse.
Doch. Siehe HT12-Datenblatt ht tp://www.alldatasheet.com/datasheet-pdf/pdf/64408/HOLTEK/HT12A.html , Seite 12, für den HT12E.
Das ist die Sendervariante mit 12 Address-Bits und Taster nach /TE. Beobachte mit dieser Schaltung Pulse an DOUT.

> Ansonsten würde die Schaltung nicht funktionieren. Aber irgend einen Sinn muss der doch haben, sonst wäre er nicht auf einen Pin gelegt.
Die meisten der "Anleitungen" die ich z.B. auf Youtube und Instructables finden kann kommen offensichtlich aus dem Raum Asien-Pazifik (Pakiastan, Indien, Argentinien, ...)
und verwenden alle den Schaltplan des HT12A mit den 4 Datenbits obwohl sie stolz den HT12E einbauen. Das gibt dann wohl Dauersenden, auch Dauernd "Daten 0", aber das ist in Nicht-Deutschland hoffentlich OK und geduldet bis gewünscht.
Auffällig ist daß die Herrschaften durch die Bank weg 4 zumeist mit LEDs dekodierte Ausgänge nutzen, was ja für die Anwendung als Windrad-Impulsgeber garnicht notwendig ist.

Am Empfänger, dem HT12D müßte das zur Pulsauswertung geeignetere Rignal an "VT" rauskommen, nicht wie bei Dir gezeigt am Daten/Address-Dekodierausgang D0
Das Datenblatt wäre ht tp://www.alldatasheet.com/datasheet-pdf/pdf/64411/HOLTEK/HT12D-18.html und z.B. auf Seite 6 ist ein interssantes Timing-Diagramm:
Auch kurze Pulse am Enable-Eingang des Encoders (muß wohl /TE sein) führen zu einem kompletten Sendewort und zu einem mindestens 214 Takten, bei z.B. 150 kHz also mindestens 0.1 Sekunden Länge. Damit zusammehängend dann auch die maximale Übertragungsgeschwindigkeit von 5-10 Pulsen pro Sekunde.
Ebenfalls dort im Datenblatt ist ersichlich daß für die Übertragug der Einzelpulses wohl ein HT12F (ohne Daten-Dekoder) vermutlich besser geeignet wäre.
Immerhin kann man den Daten-Dekoder ignorieren, wenn man das Signal an VT nutzt. Gerade mit einem Oszilloskop sollten sich da problemlos Pulse sehen lassen.
Oder häng' eine LED dran und achte auf die Lichtblitze. Die LED muß mit wenig Strom klar kommen, der Ausgang VT liefert maximal 1.6 mA.

Ich würde es ja selber fast gerne versuchen wollen, aber dabei habe ich ein Beschaffungsproblem: Wo hast Du die Dinger gekauft? Waren die teuer?

> Das Sendermodul soll angeblich nur dann senden, wenn es einen Impuls erhält und danach wieder in den Ruhezustand übergehen. Das wäre dann ok.
Ich denke nicht. Laut Datenblatt (mehr habe ich dazu nicht) sollte der HT12E bei auf Masse gelegtem /TE unabhängig von AD8-AD11 dauersenden und laufend Pulse an das Sendermodul geben.
Das wäre dann eher nicht ok. Müßtest Du aber im Oszilloskop gut sehen, oder?

> Für weitere Vorschläge bezüglich der Schaltung, wäre ich dankbar.
Wie gesagt, der Puls-Ausgang sollte an VT sein. Kannst Du da was messen? Wenn Dauer-High: Trenne am Sender mal /TE, keht das dann auf low ?

-Theo


63512 Re: Impulsübertragung per Funk - Harry 26. Januar 2018 21:53:2263511

Hallo Harry,
> Nach einigen Versuchen mit verschiedenen Schaltungsvarianten bin ich jetzt letztlich an der im Schaltbild angegebenen Version hängen geblieben.
> [ ht tps://imgur.com/8KPMHNJ ]
> Ich habe diese Schaltung auf Steckboard und auf Lochraster aufgebaut und 2 Tage lang getestet. Bis jetzt ist noch kein Fehler aufgetreten.
Glückwunsch, es funktioniert!
Im aktuellen Schaltschema (ein Plan ist es offensichtlich nicht denn z.B. die Keramikkondensatoren and en IC-Versorgungen sind nicht eingezeichnet)
sehe ich wieder "315 MHz" Funkmodul. Wie kommt das? Servierst Du uns hier Schaltschemata anderer Leute oder Hast du wirklich wieder ein nicht lizenziertes 315 MHz-Modul eingebaut?
> Den Anschluss am HT12E (Transmission enable TE) konnte ich nirgendwo anders unterbringen als an Masse.
Doch. Siehe HT12-Datenblatt ht tp://www.alldatasheet.com/datasheet-pdf/pdf/64408/HOLTEK/HT12A.html , Seite 12, für den HT12E.
Das ist die Sendervariante mit 12 Address-Bits und Taster nach /TE. Beobachte mit dieser Schaltung Pulse an DOUT.
> Ansonsten würde die Schaltung nicht funktionieren. Aber irgend einen Sinn muss der doch haben, sonst wäre er nicht auf einen Pin gelegt.
Die meisten der "Anleitungen" die ich z.B. auf Youtube und Instructables finden kann kommen offensichtlich aus dem Raum Asien-Pazifik (Pakiastan, Indien, Argentinien, ...)
und verwenden alle den Schaltplan des HT12A mit den 4 Datenbits obwohl sie stolz den HT12E einbauen. Das gibt dann wohl Dauersenden, auch Dauernd "Daten 0", aber das ist in Nicht-Deutschland hoffentlich OK und geduldet bis gewünscht.
Auffällig ist daß die Herrschaften durch die Bank weg 4 zumeist mit LEDs dekodierte Ausgänge nutzen, was ja für die Anwendung als Windrad-Impulsgeber garnicht notwendig ist.
Am Empfänger, dem HT12D müßte das zur Pulsauswertung geeignetere Rignal an "VT" rauskommen, nicht wie bei Dir gezeigt am Daten/Address-Dekodierausgang D0
Das Datenblatt wäre ht tp://www.alldatasheet.com/datasheet-pdf/pdf/64411/HOLTEK/HT12D-18.html und z.B. auf Seite 6 ist ein interssantes Timing-Diagramm:
Auch kurze Pulse am Enable-Eingang des Encoders (muß wohl /TE sein) führen zu einem kompletten Sendewort und zu einem mindestens 214 Takten, bei z.B. 150 kHz also mindestens 0.1 Sekunden Länge. Damit zusammehängend dann auch die maximale Übertragungsgeschwindigkeit von 5-10 Pulsen pro Sekunde.
Ebenfalls dort im Datenblatt ist ersichlich daß für die Übertragug der Einzelpulses wohl ein HT12F (ohne Daten-Dekoder) vermutlich besser geeignet wäre.
Immerhin kann man den Daten-Dekoder ignorieren, wenn man das Signal an VT nutzt. Gerade mit einem Oszilloskop sollten sich da problemlos Pulse sehen lassen.
Oder häng' eine LED dran und achte auf die Lichtblitze. Die LED muß mit wenig Strom klar kommen, der Ausgang VT liefert maximal 1.6 mA.
Ich würde es ja selber fast gerne versuchen wollen, aber dabei habe ich ein Beschaffungsproblem: Wo hast Du die Dinger gekauft? Waren die teuer?
> Das Sendermodul soll angeblich nur dann senden, wenn es einen Impuls erhält und danach wieder in den Ruhezustand übergehen. Das wäre dann ok.
Ich denke nicht. Laut Datenblatt (mehr habe ich dazu nicht) sollte der HT12E bei auf Masse gelegtem /TE unabhängig von AD8-AD11 dauersenden und laufend Pulse an das Sendermodul geben.
Das wäre dann eher nicht ok. Müßtest Du aber im Oszilloskop gut sehen, oder?
> Für weitere Vorschläge bezüglich der Schaltung, wäre ich dankbar.
Wie gesagt, der Puls-Ausgang sollte an VT sein. Kannst Du da was messen? Wenn Dauer-High: Trenne am Sender mal /TE, keht das dann auf low ?
-Theo


Hallo Theo,

möchte gleich Deine Fragen beantworten.

- in meinen ersten Beiträgen zu diesem Thema habe ich irrtümlich den Sender mit 366 Mhz, anstatt mit 315 Mhz angegeben. Dieses Sender- Empfänger-Duo habe ich bei einem hier ortsansässigen Elektronikladen besorgt. Der Inhaber sagte mir, dass diese Sender ohne Probleme benutzt werden können, da sie nur Senden, wenn ein Signal anliegt. Die Sender mit 466 Mhz hatte er gerade nicht vorrätig. Ich werde mir diese aber besorgen und dann austauschen.

- Am Pin VT des Dekoders HT12D messe ich ein Dauerhigh. Nur wenn ein Impuls eintrifft, geht es kurz auf low, entsprechend der Zeit des Monoflops. Wenn ich dieses Signal in den Zähler gebe, werden immer 2 Impulse gezählt. An meinem Oszilloskop kann ich aber nur ein Signal erkennen.

- Die De- Encoder habe ich bei der Firma

Elmotex elektronik
Rußwurmstraße 26
92421 Schwandorf
www.elmotex.de

gekauft. Ich habe jeweils 3 Stück zum Preis von je 0,63 Cent bestellt. Alles zusammen war es dann 1,89 Euro. Allerdings kommt noch eine Versandpauschale von 5,95 Euro sowie eine Zahlartgebühr (Paypal) hinzu, sodass ich zusammen 11,23 Euro bezahlt habe. Die Lieferung war innerhalb 2 Tagen hier.

Den Sender habe ich momentan auf Platine gelötet und kann so nicht ohne weiteres TE trennen, um festzustellen, ob das Dauer-high ausbleibt. Ich werde diese Schaltung aber nochmals auf Steckbrett aufbauen und es dort versuchen.

Gruß Harry


63527 Re: Impulsübertragung per Funk - Harry 07. Februar 2018 21:38:1163512

Hallo Harry,
> Nach einigen Versuchen mit verschiedenen Schaltungsvarianten bin ich jetzt letztlich an der im Schaltbild angegebenen Version hängen geblieben.
> [ ht tps://imgur.com/8KPMHNJ ]
> Ich habe diese Schaltung auf Steckboard und auf Lochraster aufgebaut und 2 Tage lang getestet. Bis jetzt ist noch kein Fehler aufgetreten.
Glückwunsch, es funktioniert!
Im aktuellen Schaltschema (ein Plan ist es offensichtlich nicht denn z.B. die Keramikkondensatoren and en IC-Versorgungen sind nicht eingezeichnet)
sehe ich wieder "315 MHz" Funkmodul. Wie kommt das? Servierst Du uns hier Schaltschemata anderer Leute oder Hast du wirklich wieder ein nicht lizenziertes 315 MHz-Modul eingebaut?
> Den Anschluss am HT12E (Transmission enable TE) konnte ich nirgendwo anders unterbringen als an Masse.
Doch. Siehe HT12-Datenblatt ht tp://www.alldatasheet.com/datasheet-pdf/pdf/64408/HOLTEK/HT12A.html , Seite 12, für den HT12E.
Das ist die Sendervariante mit 12 Address-Bits und Taster nach /TE. Beobachte mit dieser Schaltung Pulse an DOUT.
> Ansonsten würde die Schaltung nicht funktionieren. Aber irgend einen Sinn muss der doch haben, sonst wäre er nicht auf einen Pin gelegt.
Die meisten der "Anleitungen" die ich z.B. auf Youtube und Instructables finden kann kommen offensichtlich aus dem Raum Asien-Pazifik (Pakiastan, Indien, Argentinien, ...)
und verwenden alle den Schaltplan des HT12A mit den 4 Datenbits obwohl sie stolz den HT12E einbauen. Das gibt dann wohl Dauersenden, auch Dauernd "Daten 0", aber das ist in Nicht-Deutschland hoffentlich OK und geduldet bis gewünscht.
Auffällig ist daß die Herrschaften durch die Bank weg 4 zumeist mit LEDs dekodierte Ausgänge nutzen, was ja für die Anwendung als Windrad-Impulsgeber garnicht notwendig ist.
Am Empfänger, dem HT12D müßte das zur Pulsauswertung geeignetere Rignal an "VT" rauskommen, nicht wie bei Dir gezeigt am Daten/Address-Dekodierausgang D0
Das Datenblatt wäre ht tp://www.alldatasheet.com/datasheet-pdf/pdf/64411/HOLTEK/HT12D-18.html und z.B. auf Seite 6 ist ein interssantes Timing-Diagramm:
Auch kurze Pulse am Enable-Eingang des Encoders (muß wohl /TE sein) führen zu einem kompletten Sendewort und zu einem mindestens 214 Takten, bei z.B. 150 kHz also mindestens 0.1 Sekunden Länge. Damit zusammehängend dann auch die maximale Übertragungsgeschwindigkeit von 5-10 Pulsen pro Sekunde.
Ebenfalls dort im Datenblatt ist ersichlich daß für die Übertragug der Einzelpulses wohl ein HT12F (ohne Daten-Dekoder) vermutlich besser geeignet wäre.
Immerhin kann man den Daten-Dekoder ignorieren, wenn man das Signal an VT nutzt. Gerade mit einem Oszilloskop sollten sich da problemlos Pulse sehen lassen.
Oder häng' eine LED dran und achte auf die Lichtblitze. Die LED muß mit wenig Strom klar kommen, der Ausgang VT liefert maximal 1.6 mA.
Ich würde es ja selber fast gerne versuchen wollen, aber dabei habe ich ein Beschaffungsproblem: Wo hast Du die Dinger gekauft? Waren die teuer?
> Das Sendermodul soll angeblich nur dann senden, wenn es einen Impuls erhält und danach wieder in den Ruhezustand übergehen. Das wäre dann ok.
Ich denke nicht. Laut Datenblatt (mehr habe ich dazu nicht) sollte der HT12E bei auf Masse gelegtem /TE unabhängig von AD8-AD11 dauersenden und laufend Pulse an das Sendermodul geben.
Das wäre dann eher nicht ok. Müßtest Du aber im Oszilloskop gut sehen, oder?
> Für weitere Vorschläge bezüglich der Schaltung, wäre ich dankbar.
Wie gesagt, der Puls-Ausgang sollte an VT sein. Kannst Du da was messen? Wenn Dauer-High: Trenne am Sender mal /TE, keht das dann auf low ?
-Theo

Hallo Theo,
möchte gleich Deine Fragen beantworten.
- in meinen ersten Beiträgen zu diesem Thema habe ich irrtümlich den Sender mit 366 Mhz, anstatt mit 315 Mhz angegeben. Dieses Sender- Empfänger-Duo habe ich bei einem hier ortsansässigen Elektronikladen besorgt. Der Inhaber sagte mir, dass diese Sender ohne Probleme benutzt werden können, da sie nur Senden, wenn ein Signal anliegt. Die Sender mit 466 Mhz hatte er gerade nicht vorrätig. Ich werde mir diese aber besorgen und dann austauschen.
- Am Pin VT des Dekoders HT12D messe ich ein Dauerhigh. Nur wenn ein Impuls eintrifft, geht es kurz auf low, entsprechend der Zeit des Monoflops. Wenn ich dieses Signal in den Zähler gebe, werden immer 2 Impulse gezählt. An meinem Oszilloskop kann ich aber nur ein Signal erkennen.
- Die De- Encoder habe ich bei der Firma
Elmotex elektronik
Rußwurmstraße 26
92421 Schwandorf
www.elmotex.de
gekauft. Ich habe jeweils 3 Stück zum Preis von je 0,63 Cent bestellt. Alles zusammen war es dann 1,89 Euro. Allerdings kommt noch eine Versandpauschale von 5,95 Euro sowie eine Zahlartgebühr (Paypal) hinzu, sodass ich zusammen 11,23 Euro bezahlt habe. Die Lieferung war innerhalb 2 Tagen hier.
Den Sender habe ich momentan auf Platine gelötet und kann so nicht ohne weiteres TE trennen, um festzustellen, ob das Dauer-high ausbleibt. Ich werde diese Schaltung aber nochmals auf Steckbrett aufbauen und es dort versuchen.
Gruß Harry


Habe nun noch eine Version gefunden, bei der nur dann gesendet wird, wenn am Encoder ein Signal anliegt. Als Encoder habe ich den Baustein PT2262 und als Decoder den Baustein PT2272 benutzt.
Die Schaltung kann hier eigesehen werden: (h t t p s bitte zusammen schreiben, oder das Leerzeichen rauslöschen)

htt ps://imgur.com/a/UKEYf


Schreib einen Text •  • Forum •  • Neue Beiträge

| ©www.HobbyElektronik.de | ©Knolle_P | (©Oliver Pering) |